Description of Challenge
End User attempting to use either the Mobile App or Web App receives an error similar to the screenshot below.
"Check that your account is registered with your IT Service Provider or IT Department."
Cause
End User Email and/or Mobile Number is not registered on the Quickpass Dashboard for the End User.
Both the email and Mobile Number are required to be populated with valid data before an End User can log into the App.
Resolution
- Manually Populate the Email Address and Phone Number
- Quickpass Login Roles can populate the Email Address and/or Mobile Number directly from the Dashboard.
- For the email address this needs to be formatted with valid email address (email@domain.com)
- For the Mobile Number, this needs to include the "+" character and the Regional Dialing Code. (North America is +1, UK is +44, etc)
- Quickpass Login Roles can populate the Email Address and/or Mobile Number directly from the Dashboard.
- Update the Directory Source
- At the time of this KB being created there is not a 2 Way Sync between the Directory Source and the Quickpass Dashboard. This means the account will need to be deleted off the dashboard (this does NOT delete the account from the Source)
- After the account is deleted from the Dashboard, update the Directory Source information for the End User Account in question.
- If the Automatic Import of accounts is currently configured, the account will be re-imported at the time of the next import cycle.
- If a Manual import of accounts was done, you can simply reimport the account manually from the Directory Source.
- Send the Welcome Email
- If the Email Address IS populated on the dashboard, you can send the End User the Welcome email to have them populate the Mobile number.
- When the End User receives the Welcome Email, they MUST click the link to register their Mobile Number. This link will allow them to select their country and enter the Mobile Number.
Once they enter their Mobile Number, a 6 digit code will be sent to the End User via SMS/Text Message to confirm they have entered the Mobile Number correctly. Once the End User confirms that code, and clicks submit, the Mobile number will now populate the Dashboard. The End User can then download and install the Mobile App, or use the Web App if more appropriate (https://app.getquickpass.com)
Additional Steps
If the End User does not receive the initial SMS/Text message when registering their Mobile number, please see this article for additional Troubleshooting of SMS.
https://support.getquickpass.com/hc/en-us/articles/1500010691342-SMS-Messages-not-Received-by-End-Users
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