Description of Challenge
The server agent will not come online or will not install on a Server or Workstation that has threat protection enabled
Cause
The issue affects customers that use a threat protection product on their Active Directory servers where the agent is installed, and that threat protection detects the Quickpass process as an unidentified process, blocking it from running.
Resolution
- Quickpass Digitally signs the installation and execution programs. Your first course of action should be to attempt to add our Digital Signature to the Whitelist for your Threat Protection.
- If Whitelisting the Digital Certificate is not an option for the Threat Protection in place, an alternate solution is to add a whitelist/exclusion entry for the Quickpass program files path of C:\Program Files\Quickpass Software (and subfolders)
C:\ProgramData\Quickpass Software
And whitelist if possible the service:
ThreatLocker or Similar Protection Firewall
ThreatLocker has a policy called “RunDLL - Block Internet (Ringfenced)” which is by default applied to each workstation and server group. Other Threat Protection applications may have something similar in place to prevent unknown applications from communicating with the internet when not approved. This policy needs to be updated to allow the FQDN in the INTERNET ringfencing.
Please review the specific KB for ThreatLocker:
https://support.getquickpass.com/hc/en-us/articles/27229768980503-ThreatLocker-configuration-for-use-with-Quickpass-Server-Agent
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- See this KB on what IPs and FQDN/DNS entries to unblock.
https://support.getquickpass.com/hc/en-us/articles/4402712146711-Firewall-Port-Exceptions-IP-Whitelisting-for-Agent-and-API-Communication
- See this KB on what IPs and FQDN/DNS entries to unblock.
DNS/Web Filtering
Ensure the Quickpass IPs/DNS entries listed above are unblocked/whitelisted/added if you have Web or DNS filtering service enabled
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