Description of Issue
The server agent will not come online or will not install on a Server or Workstation that has threat protection enabled
Cause
The issue affects customers that use a threat protection product on their Active Directory servers where the agent is installed, and that threat protection detects the Quickpass process as an unidentified process, blocking it from running.
Resolution
- The solution is to add a white list entry for the Quickpass program files path of C:\Program Files\Quickpass Software (and subfolders)
C:\ProgramData\Quickpass Software
And whitelist if possible the service: - You can also whitelist the signature file for the installation file
ThreatLocker
ThreatLocker has a policy called “RunDLL - Block Internet (Ringfenced)” which is by default applied to each workstation and server group. This policy needs to be updated to allow the FQDN in the INTERNET ringfencing.
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- See this KB on what IPs and FQDN/DNS entries to unblock.
https://support.getquickpass.com/hc/en-us/articles/4402712146711-Firewall-Port-Exceptions-IP-Whitelisting-for-Agent-and-API-Communication
- See this KB on what IPs and FQDN/DNS entries to unblock.
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