Description of Issue
You connect a Quickpass customer to an Office 365 / Azure tenant account and the password policy does not properly download to the Password Settings link in the Quickpass web dashboard.
In addition, the password expiration dates for Office 365 accounts imported into Quickpass are not accurate.
Cause
In some older Office 365 / Azure tenant accounts if the default password policy was never changed the value presented from the Microsoft graph API is null. Subsequently, the values downloaded by Quickpass from the Microsoft Graph API are missing resulting in the password policy shown in Quickpass to be blank.
Resolution
The work around for this issue is to login into the Office 365 Admin Center for this tenant and edit the password policy with a different value than the default.
1. Login to the Office 365 Admin Center (Now called the Microsoft 365 Admin Center) at portal.office.com then click the Admin Center link.
2. On the left hand menu go to Settings then select Org settings
3. Click Security & privacy tab and then Password expiration policy link.
4. Change the number of days in the Days before passwords expire box then click save to Apply.
For example, if the number is 90 then change it to 91.
If the policy is set to never expire then switch to expires and input a number.
5. Go back to Quickpass and verify that the password policy in Password Settings is now updated.
6. You can now switch the Office 365 password policy back to what it was before and the password policy should still be populated in Quickpass password settings.
Comments
0 comments
Please sign in to leave a comment.