Description of Challenge
After the 3.1.5.0 release of the Quickpass agent, some Application plugins/add-ins that use the NET.PIPE communication are giving an error.
Cause
NET.PIPE is a commonly used protocol to communicate within the system for Application Plugin/Add-ins. Normally these applications should share the NET.PIPE communication protocol. However in some cases application plugins/add-ins may fail to load or work properly when this Quickpass Agent version has been installed.
Applications known to be affected:
- "NetDocuments"
- Mimecast
- CAD Based Applications using Bentley Licensing
- PatientNow – Medical scanner
The Quickpass Development team is doing additional investigations to isolate how this NET.PIPE is affected and this should be resolved in the future. Until this update can be released, the following workarounds are available.
Resolution
Stop Quickpass Validation Service
This service was added to the AD Workstation (Windows 10 or 11 systems joined to Traditional Active Directory).
Stopping this service and disabling it will stop the Quickpass Agent from using the NET.PIPE communication protocol.
NOTE: This will stop the Cached Credential update functionality that was released with 3.1.5.0 of the Agent.
https://support.getquickpass.com/hc/en-us/articles/10850794644119-Active-Directory-Cached-Credentials-Update
Downgrade the Agent
Uninstalling the 3.1.5.0 version of the Agent and reinstalling the Agent with version 3.0.22.0 will prevent this error from occurring. If the MSP doesn't have a copy of the 3.0.22.0 agent available, please reach out to support@getquickpass.com and request a copy of that older agent to install.
We would suggest pausing the Automatic Update Task on each machine in question to prevent it from being updated to 3.1.5.0 again.
- Find and Launch Task Scheduler
- Click on Task Scheduler Library.
- Find the Quickpass Updater on the list of Tasks
- Right click the Updater and select Disable
- The Status Column should display "Disabled" as confirmation that this has been turned off.
NOTE: Updates to this KB will be supplied when this is resolved. Please subscribe to this KB so that you can be notified when the fix is in place.
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